
SonicWall Patches Critical Path Traversal and Update Flaws in NetExtender for Linux
SonicWall has released fixes for two high-severity vulnerabilities in its NetExtender client for Linux that could allow remote attackers to write arbitrary files with root privileges and manipulate the automatic update process. The flaws impact versions 10.3.5 and earlier, while the Windows version remains unaffected. CVE-2026-66152 carries a CVSS score of 8.8 and stems from improper handling of tar archives containing OPSWAT data, enabling path traversal that lets attackers escape the intended extraction directory. CVE-2026-66153 scores 7.0 and arises from inadequate symlink and temporary file handling in the NEService update mechanism. Both issues require user interaction to exploit, and no in-the-wild attacks have been observed so far. Administrators are urged to upgrade immediately to version 10.3.6 or later, as no workarounds exist.
BoletimSecAug 27, 2026Translated from Portuguese